Page 1 of 1

Extrudermotor wird nicht mehr angesteuert

Posted: Thu Jul 27, 2017 7:05 pm
by edefault
Dass sich das Filament in das Innere des Extrudergehäuses verflüchtigt, anstatt bei der Düse heraus zu kommen ist mir nun leider auch passiert, und mit ganz normalem PLA, nicht mal mit elastischem Material. Um den verworrenen Rest des Filaments zu Entfernen muss der Druckkopf auseinander... st ja keine Raketenwissenschaft, nur:

Nach dem Zerlegen und wieder Zusammensetzen bekomme ich jetzt den Extrudermotor nicht mehr bewegt 8-( ... kein Stück.
Das Machine Control Panel von SImplify3D erlaubt, die "Achsen" einzeln anzusteuern: X, Y, Z - perfekt. Heizung Druckbett & Düse auch.

Nur der verflixte Extrudermotor rührt sich nicht. Da der aber eigentlich nicht kaputt sein kann, muss es wohl am Kabel, den Steckern oder der Platine liegen! Mal die farbigen Stecker der Schrittmotoren vertauscht, und siehe: Am Motor liegt's tatsächlich nicht. Die Platine tut am blauen Anschluss für den Extrudermotor nichts heraus.

Was kann das sein? Und wieso?
Danke.

Re: Extrudermotor wird nicht mehr angesteuert

Posted: Thu Jul 27, 2017 11:25 pm
by AndyF
Teste mal, ob der Motor ohne Spannung drehbar ist und ob sich was bei Spannung ändert.

Gruß
Andreas

Re: Extrudermotor wird nicht mehr angesteuert

Posted: Fri Jul 28, 2017 10:29 am
by edefault
Das habe ich schon getestet ... der Extruder-Motor funktioniert (wie oben beschrieben), wenn ich ihn an einen anderen Ausgang (X, Y, Z) anklemme.
Ich muss wohl als nächstes mal die Platinen-Baugruppe auseinander nehmen und schauen, ob ich eine gerissene Lötstelle oder Leiterbahn finde. Wenn nicht, brauche ich wohl eine neue Platine.

EDIT: Hab alles auseinander genommen - und kann optisch keinen Fehler finden.

Re: Extrudermotor wird nicht mehr angesteuert

Posted: Fri Jul 28, 2017 12:23 pm
by AndyF
Ah, ok. Die Schrittmotorentreiber hab ich mir noch nicht angesehen.
Wenn nicht, baust Du das auf ne gängigere Platine um und hast dann doch mehr Einfluss auf die Parameter.

Gruß
Andreas

Re: Extrudermotor wird nicht mehr angesteuert

Posted: Fri Jul 28, 2017 2:01 pm
by edefault
'ne gängigere Platine
... genau das suche ich jetzt ... denn genau die gleiche irgendwo aufzutreiben wird wohl nicht klappen.

Re: Extrudermotor wird nicht mehr angesteuert

Posted: Fri Jul 28, 2017 4:03 pm
by AndyF
Im Kodama Store 60€, wenn ich mich nicht versehen habe.

https://eu.kodama3d.com/collections/spa ... 3487931524

Ich würde da aber eher zu RADDS oder ähnlichem tendieren, wenn man es selbst technisch umsetzen kann.
Da hat man halt deutlich mehr Eingriffsmöglichkeiten von Hause aus.

Gruß
Andreas

Re: Extrudermotor wird nicht mehr angesteuert

Posted: Tue Aug 22, 2017 9:40 am
by edefault
Ich habe so eine Ersatzplatine aus dem Kodama Store eingebaut, es funktioniert wieder. Aber ich bin nach dem Einbau noch mal kurz auf das gleiche Fehlverhalten gestoßen, konnte aber dann die erneut probehalber umgestöpselten Schrittmotoren aus dem Geräte-Bedienfeld von S3D doch einwandfrei ansteuern... kurzum, ich bin nicht mehr so sicher, ob da tatsächlich die Platine defekt war.

Je tiefer ich mich einlese, um so mehr ungemütliche Eigentümlichkeiten entdecke ich. Sicherheitshalber habe ich ein aktuelles FFF Profil von Kodama heruntergeladen, mit dem der Druck aus S3D (Ubuntu, USB) nun zumindest beginnt ... aber er kommt nicht weit.

In vier Versuchen ist der Trinus nicht über das erste Layer hinaus gekommen: Der Filamentantrieb klackert irgendwann und es kommt kein Material mehr heraus. Klemmen tut da aber nichts (was mir auch schon vorgekommen ist), alles ist frisch gereinigt und neu zusammen gebaut.

Die Düse ist nicht richtig heiß, kein Wunder, dass nichts mehr heraus kommt. Ob wohl die Software die Heizung abgeschaltet hat?
Das kann ich leider nicht verifizieren, mangels korrekter Temperaturanzeige in S3D - die Firmware des Trinus ist nicht kompatibel damit :-(

Re: Extrudermotor wird nicht mehr angesteuert

Posted: Sun Aug 27, 2017 10:20 am
by edefault
Neue Platine ... neues Hotend ... neue Software (S3D 4.0).
Nach kurzer Zeit gleiches Fehlverhalten: Keine Regung von Schrittmotoren am blauen Ausgang.
Extrudermotor am grünen Ausgang funktioniert... aber es gibt einen Hinweis, dass S3D irgendwas blockiert:
    Versuche bei /dev/ttyUSB0 eine Verbindung aufzubauen...
    LESEN: start
    Verbindung mit dem Gerät hergestellt!
    LESEN: Machine: Panowin F1 3D Printer
    LESEN: Firmware: Paladin 3.6.2-D3
    LESEN: Release date: Mar 28 2017 18:31:23
    LESEN: Manufacturer: Panowin Technologies.
    LESEN: Website: http://www.panowin.com
    GESENDET: T0
    LESEN: [ECHO] SD card ok
    LESEN: [ERROR] gcode char invalid: 'T' (54)
    LESEN: [ERROR] gcode char invalid: '0' (30)
    LESEN: [ERROR] invalid gcode
    LESEN: ok
    GESENDET: M105
    LESEN: [VALUE] T:24.0/0.0 B:23.5/0.0 S:0 F:'' P:-1 I:0 D:100 E:100
    LESEN: ok
    [...]
    GESENDET: G91
    GESENDET: G1 E-10.0000 F240
    GESENDET: G90
    LESEN: ok
    LESEN: ok
    LESEN: [ERROR] cold extrusion prevented
    LESEN: ok
    GESENDET: G91
    GESENDET: G1 E-10.0000 F240
    GESENDET: G90
    LESEN: ok
    LESEN: ok
    LESEN: [ERROR] cold extrusion prevented
    LESEN: ok
    GESENDET: G91
    GESENDET: G1 E-10.0000 F240
    GESENDET: G90
    LESEN: ok
    LESEN: ok
    LESEN: [ERROR] cold extrusion prevented
    LESEN: ok

"cold extrusion prevented" taucht hier auf, sobald ich den Extrudermotor anzusteuern versuche.
Dasselbe passiert nach einigen Minuten während des Druckens. Der Druckvorgang läuft weiter, nur ohne Extrusion.

Re: Extrudermotor wird nicht mehr angesteuert

Posted: Thu Aug 31, 2017 2:21 pm
by edefault
Fortsetzung: Neuer Versuch mit dem stärkeren Netzteil (Kodama Shop NL) und einem LCD Display (dto.; darauf hatte ich bisher verzichtet).
Ganz orthodox mit dem WIndows Computer eines Bekannten Pango installiert, Teil platziert und "pcode" auf SD Karte geschrieben.
Spannend!
Der Druckstart vom Display - ohne S3D und Computer - legt sofort los, aber 1. wird das Heizbett nicht warm und 2. stimmt der Z-Offset nicht.
Viel zu tief! Deutlich nachjustiert, und jetzt läuft der Druck durch :-)
Was da wohl S3D daran gehindert hat, ist mir völlig schleierhaft. Da stehen noch weitere Versuche an.
Auf jeden Fall bin ich schon mal erleichteret, dass die Hardware funktioniert - obwohl ich jetzt viele Teile doppelt besitze.

Re: Extrudermotor wird nicht mehr angesteuert

Posted: Thu Oct 26, 2017 5:48 pm
by edefault
So ... nach etlichen weiteren Um- und Anbauten in ich mir sicher: S3D verhindert die Betätigung des Extrudermotors, so lange nicht die Solltemperatur am Hot End (annähernd) erreicht ist.
Das habe ich mit einem fliegenden Aufbau erprobt ... erst wenn das Hot End richtig heiss ist, lassen sich alle Schrittmotoren über die sog. Tipp-Kontrollen im Geräte-Bedienfeld ansteuern.

Ob die Extrusion dann auch was liefert, hängt dann "nur" noch von der Laune der Düse, dem Reibwert im Teflonröhrchen und dem Eingriff des Antriebsröllchens am Filament ab 8-)